Author: Halfvares Mats, Teknikhuset AB.

Published: 2006-06-26

Applies to:
  • Content Studio ver. 3.3 and later running on SQL Server 2000.

Type: Information


Symptoms

When you try to update a document time out occurs or the save operation takes a very long time. After an failed update the document content might get updated but EPT filters does not work as expected. The site works as usually.

Cause

This problem can occur if the Xml index data full text index in SQL Server 2000 is corrupt.

Resolution

You can rebuild the full text index to have SQL Server correct the corrupt data. In Enterprise Manager open the actual site database and select the Full-Text Catalogs folder. You should see two entries in the pane to the right:
  • ftxt_NN_CS_ContentBinary
  • ftxt_NN_CS_XmlData

where NN represents the database ID.

Right click on the ftxt_NN_CS_XmlData item an select Rebuild catalog. This will force SQL Server to tear down the entire index, rebuild it from scratch and reindex all xml data. Hopefully this will correct the corrupt index. The operation can take a very long time to perform and is not finished until the index reports that the catalog i idle. The ftxt_NN_CS_XmlData catalog contains the index of EPT data that enables developers to use the CONTAINS search operations.

While at it, consider rebuilding the ftxt_NN_CS_ContentBinary as well. This index contains all full-text indexed document data and can grow to a considerable size with time and if the web site is large. The rebuild process is done in the same way as the former operation but requires that you manually start a full population after that the rebuild process has been finished.

Status

This is a problem with the Microsoft SQL Server 2000 full-text indexing functionality. SQL Server 2005 has a new full-text indexing engine and we have not yet seen this problem with this product.